Yio Remote Community

Discovered Integrations Crash my remote

Hello,

I have just received my assembled remote and try to configure it.

At starting up I have connected my remote to my WIFI but then I was not able to connect my dock through the remote so I have done it by using the WiFi network called “YIO-Dock-xxxxxxxxxxxxxxxx"

My remote is successfully connected to WiFi and I can reach the OTA webpage. However my remote is unable to discover the dock (Discovered integration is empty)

When I used “search for integration on your network” it crash the remote and I need to reboot it.

Hi @Nicolas1er,

did you update the app, plugins and the web configurator on the remote?

When I access to the remote by the web configurator I go in the menu sofware update, click on “Check For Update” and nothing happen, I just can read your software is up to date (installed version 1.0.0)

The software update functionality is not working.

You can manually update the files:

Super thanks, it works now, next step Homeassitant intégration…

Glad it worked out! Homeassistant should be quite straightforward :slight_smile:

Not so easy for me… Is there any tutorial ? Should I used SSH connection ? Should I need the tokens and if, where I can find or create them in homeassistant.

Yes I know I’m little bit newbie… but with some explanation and help I can and I will be happy to understand.

  1. In Home Assistant, go to your user Profile. It should be on the left sidebar in the bottom. Then scroll down to Long-Lived Access Tokens. Create a new token. Write it down somewhere.

  2. On the remote, go to Settings and turn on Remote configuration.

  3. Open up a web browser on your computer and navigate to the website the remote says. It should be something like http://192.168.1.10

  4. Go to Integrations and add a new one in the right sidebar. Here you can enter the IP address and port of your home assistant server, for example: 192.168.1.20:8123. Enter the token and hit save.
    If you are using a reverse proxy with SSL, enter the domain and port of your home assistant instance and turn on SSL. If you have a self signed certificate turn on disable ssl verification.

  5. After this, go to the Entities page and choose the entities you’d like to control with the remote. Please note that the weather entity is not yet supported in home assistant. Do not add this otherwise it will crash the remote probably :slight_smile:

Really thanks for your time Marton, I will work on it !

YES ! It works like a charm ! run smoothly, I love it. Now I’m waiting for “IR/TV remote" integration stable

1 Like