Yio Remote Community

Guidance on use of GitHub

Any chance someone who knows how to navigate/use GitHub could provide some guidance on how the process works. Particularly with reporting bugs and feature requests. Also perhaps how to propose changes to the code? I have no idea and have already spotted a few easy to fix bugs (i.e. proximity setting control allows value of less than 10) or features that would help (i.e. validation for “hanging” entities after updating an integration).

You can check out the development wiki:

And can easily open issues here:

Ah that bottom link is what I was after! As I said complete noob with GitHub!

I can’t believe I missed all the information in the wiki. Especially the Buildroot setup. On that note, I also tried to spin up a docker container for a bit of fun, but when running “init” I get the following error:

Git clone https://github.com/YIO-Remote/integration.dock.git

Cloning into ‘integration.dock’…
remote: Enumerating objects: 5, done.
remote: Counting objects: 100% (5/5), done.
remote: Compressing objects: 100% (5/5), done.
remote: Total 354 (delta 1), reused 2 (delta 0), pack-reused 349
Receiving objects: 100% (354/354), 102.09 KiB | 509.00 KiB/s, done.
Resolving deltas: 100% (177/177), done.
error: pathspec ‘dev’ did not match any file(s) known to git

The Docker build image is unfortunately a bit dated and still uses the old git branches. At least the published image, if you build the image yourself you “might” get a bit further. (We’ve changed the development model from git flow to GitHub flow recently).
I will update, test & publish the Docker build image this week!
Sorry for the bumpy start.

Is it possible to also update the guidance on https://github.com/YIO-Remote/documentation/wiki/developer-vm? I was trying to build qmake locally and it currently directs you to run “git checkout develop” which similarly fails. I’m a noob when it comes to GitHub what is the path I should be entering?

Good catch! Wiki page is updated. It was again the old develop branch which doesn’t exist anymore.
Now the default and up to date branch is master.
I’m currently testing an updated Docker image. Should be available tomorrow and I will announce it here when published.

Ah good but also bugger as I tried running make as per the updated instructions but I got an error at the end and no qmake file. I cloned everything again and will give it another shot… will check what happened tomorrow.

@nickprice The Docker build image has been fixed! I haven’t had the time to test the created sd card image, but it’s already a very good sign when Builldroot outputs an image :slight_smile:
To get the new Docker image: docker pull gcr.io/yio-remote/build
The command yio info now prints the release version:

$ yio info
Using docker image                   : gcr.io/yio-remote/build
Docker image version                 : v0.4.0-6-gcd662bd

If you use a Docker volume for the YIO source projects (and don’t mount a local project folder with YIO_BUILD_SOURCE) it’s best to re-create it, to make sure you have the required integrations.library project, which was missing in the old version:

docker volume rm yio-projects

For a complete reset, also remove the Buildroot volume: docker volume rm yio-buildroot

Thanks, worked perfectly. It’s busy compiling on my server!