Yio Remote Community

Home Assistant behind reverse proxy

I’m trying to connect the remote to my Home Assistant.
The problem is that it is in a docker network that does not expose the Home Assistant port directly, instead it is behind a Traefik reverse proxy https://docs.traefik.io/.
So I can reach home assistant by using https://myhost.mydomain and then the proxy will take care of SSL, and route to Home assistant inside the Docker network.
But that only works if I connect using the DNS name, not when using IP, and not to port 8123 only port 443 with SSL.

We discovered this a couple of days ago and fixed it. You can download latest development builds from the GitHub repos:


Unfortunately you need to copy these files manually to the remote.

  1. ssh into the remote. User: root password: yioremote
  2. killall -9 remote
  3. from your machine: copy the .so file to /opt/yio/app-plugins/
  4. from your machine: copy the remote binary to /opt/yio/app/
  5. This is not yet enabled in the web configurator so you need to go to advanced and edit the config there manually. You need to add an ssl key to config next to the ip and token. So it would look something like this:
"ip":"domain.com:port",
"token":"",
"ssl": true
  1. Save it and reboot the remote. It should work.
1 Like

That worked like a charm.

That’s good to hear! :slight_smile:

Hi, from an unexperienced use: I haven’t yet copied the image yet does that mean that i can just start with the latest version above i.e. https://github.com/YIO-Remote/integration.home-assistant/releases/tag/latest?

hi @Trouble-51,
if you download the latest SD card image, that doesn’t have these changes yet. So after burning an SD card and going through the initial setup, you’ll need to follow the instructions above to get the latest build of the integration plugin and remote app.